const regex = /(?:\(first\)|\[first]|{first})(*SKIP)(*FAIL)|\bfirst\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\(first\\)|\\[first]|{first})(*SKIP)(*FAIL)|\\bfirst\\b', 'gm')
const str = `This is a (first) test with the first hit
This is a first test
This is a (first] test with the first hit`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}