import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\(first\\)|\\[first]|\\{first\\})(*SKIP)(*FAIL)|\\bfirst\\b";
final String string = "This is a (first) test with the first hit\n\n"
+ "This is a first test\n\n\n"
+ "This is a (first] test with the first hit";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}