#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[^{\n]|{(?!{)|{{2}(?:dog|cat)}{2})+$"
Local $sString = "I own a {{dog}} and {{cat}} but not fish" & @CRLF & _
"I own a fish" & @CRLF & _
"I own a {{cow}}" & @CRLF & _
"I own a {{dog}} and a {{cow}}" & @CRLF & _
"I own a {{cat}} hah" & @CRLF & _
"I {own} a {{dog}}" & @CRLF & _
"I {own} a {{cat}} and {cow}" & @CRLF & _
"I own a {cow}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")