using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^{\n]|{(?!{)|{{2}(?:dog|cat)}{2})+$";
string input = @"I own a {{dog}} and {{cat}} but not fish
I own a fish
I own a {{cow}}
I own a {{dog}} and a {{cow}}
I own a {{cat}} hah
I {own} a {{dog}}
I {own} a {{cat}} and {cow}
I own a {cow}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}