import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^\\{\\n]|\\{(?!\\{)|\\{{2}(?:dog|cat)\\}{2})+$";
final String string = "I own a {{dog}} and {{cat}} but not fish\n"
+ "I own a fish\n"
+ "I own a {{cow}}\n"
+ "I own a {{dog}} and a {{cow}}\n"
+ "I own a {{cat}} hah\n"
+ "I {own} a {{dog}}\n"
+ "I {own} a {{cat}} and {cow}\n"
+ "I own a {cow}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}