#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^/(admin|superuser)/.*$"
Local $sString = "/admin/" & @CRLF & _
"/admin/control_panel" & @CRLF & _
"/superuser/" & @CRLF & _
"/superuser/settings" & @CRLF & _
"/web" & @CRLF & _
"/user/settings"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")