package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^/(admin|superuser)/.*$`)
var str = `/admin/
/admin/control_panel
/superuser/
/superuser/settings
/web
/user/settings`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}