$re = '`^/(admin|superuser)/.*$`m';
$str = '/admin/
/admin/control_panel
/superuser/
/superuser/settings
/web
/user/settings';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);