use strict;
my $str = 'ABC 123 Book 456 ZZZ 789 KKK XYZ';
my $regex = qr/(\d+) (\w+)/mp;
my $subst = '\\2 \\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";