import re
regex = re.compile(r"(\d+) (\w+)", flags=re.MULTILINE)
test_str = "ABC 123 Book 456 ZZZ 789 KKK XYZ"
subst = "\\2 \\1"
result = regex.sub(subst, test_str)
if result:
print(result)