$re = '/(\d+) (\w+)/m';
$str = 'ABC 123 Book 456 ZZZ 789 KKK XYZ';
$subst = "\2 \1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;