#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-zA-Z0-9_\-\.]+)(@)([a-zA-Z0-9_\-\.]+)\b"
Local $sString = "HOME PHONE # WORK / DAYTIME PHONE # CELL PHONE # E-MAIL ADDRESS 675-567-4567 234-123-1234 111-123-1234 AMARYELANE@HOTMAIL.COM"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")