$re = '/([a-zA-Z0-9_\-\.]+)(@)([a-zA-Z0-9_\-\.]+)\b/m';
$str = 'HOME PHONE # WORK / DAYTIME PHONE # CELL PHONE # E-MAIL ADDRESS 675-567-4567 234-123-1234 111-123-1234 AMARYELANE@HOTMAIL.COM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);