package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z0-9_\-\.]+)(@)([a-zA-Z0-9_\-\.]+)\b`)
var str = `HOME PHONE # WORK / DAYTIME PHONE # CELL PHONE # E-MAIL ADDRESS 675-567-4567 234-123-1234 111-123-1234 AMARYELANE@HOTMAIL.COM`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}