import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<project>^([A-Z]{1,2}[a-z\\d]+)+(_?([A-Z]{1,2}[a-z\\d]+)+)*)(?P<signature>_BIOS)_v(?P<major>(0|([1-9]\\d*)))\\.(?P<minor>(0|([1-9]\\d*)))\\.(?P<patch>(0|([1-9]\\d*)))(?P<suffix>_[\\w\\.]*)?";
final String string = "Icelake_BIOS_v0.0.0\n"
+ "Icelake_BIOS_v1.2.3\n"
+ "Icelake_BIOS_v123.456.7890\n"
+ "Icelake_BIOS_v1.0.0\n"
+ "Icelake_Emux_BIOS_v1.0.0\n"
+ "Emux_BIOS_v1.0.0\n"
+ "Icelake_BIOS_v1.0.0_QS_Alpha_Debug_SelfTest\n"
+ "Icelake_BIOS_v1.0.0_QS_Alpha_v1.0.0_Debug_SelfTes\n\n\n"
+ "icelake_BIOS_v1.0.0\n"
+ "Icelake_bios_v1.0.0\n"
+ "Icelake_emux_BIOS_v1.0.0\n"
+ "Icelake_BIOS_v01.0.0\n"
+ "Icelake_BIOS_v1.02.0\n"
+ "Icelake_BIOS_v0123.123.123\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}