const regex = /(?P<project>^([A-Z]{1,2}[a-z\d]+)+(_?([A-Z]{1,2}[a-z\d]+)+)*)(?P<signature>_BIOS)_v(?P<major>(0|([1-9]\d*)))\.(?P<minor>(0|([1-9]\d*)))\.(?P<patch>(0|([1-9]\d*)))(?P<suffix>_[\w\.]*)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<project>^([A-Z]{1,2}[a-z\\d]+)+(_?([A-Z]{1,2}[a-z\\d]+)+)*)(?P<signature>_BIOS)_v(?P<major>(0|([1-9]\\d*)))\\.(?P<minor>(0|([1-9]\\d*)))\\.(?P<patch>(0|([1-9]\\d*)))(?P<suffix>_[\\w\\.]*)?', 'gm')
const str = `Icelake_BIOS_v0.0.0
Icelake_BIOS_v1.2.3
Icelake_BIOS_v123.456.7890
Icelake_BIOS_v1.0.0
Icelake_Emux_BIOS_v1.0.0
Emux_BIOS_v1.0.0
Icelake_BIOS_v1.0.0_QS_Alpha_Debug_SelfTest
Icelake_BIOS_v1.0.0_QS_Alpha_v1.0.0_Debug_SelfTes
icelake_BIOS_v1.0.0
Icelake_bios_v1.0.0
Icelake_emux_BIOS_v1.0.0
Icelake_BIOS_v01.0.0
Icelake_BIOS_v1.02.0
Icelake_BIOS_v0123.123.123
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}