re = /(?P<project>^([A-Z]{1,2}[a-z\d]+)+(_?([A-Z]{1,2}[a-z\d]+)+)*)(?P<signature>_BIOS)_v(?P<major>(0|([1-9]\d*)))\.(?P<minor>(0|([1-9]\d*)))\.(?P<patch>(0|([1-9]\d*)))(?P<suffix>_[\w\.]*)?/m
str = 'Icelake_BIOS_v0.0.0
Icelake_BIOS_v1.2.3
Icelake_BIOS_v123.456.7890
Icelake_BIOS_v1.0.0
Icelake_Emux_BIOS_v1.0.0
Emux_BIOS_v1.0.0
Icelake_BIOS_v1.0.0_QS_Alpha_Debug_SelfTest
Icelake_BIOS_v1.0.0_QS_Alpha_v1.0.0_Debug_SelfTes
icelake_BIOS_v1.0.0
Icelake_bios_v1.0.0
Icelake_emux_BIOS_v1.0.0
Icelake_BIOS_v01.0.0
Icelake_BIOS_v1.02.0
Icelake_BIOS_v0123.123.123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end