# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*?)\bm\./\1/gm;t' <<< "https://m.gsmarena.com/sony_xperia_5_iv-price-11838.php
https://redfm.ie/
https://en.m.wikipedia.org/"