package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)\bm\.`)
var str = `https://m.gsmarena.com/sony_xperia_5_iv-price-11838.php
https://redfm.ie/
https://en.m.wikipedia.org/`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}