re = /^(.*?)\bm\./m
str = 'https://m.gsmarena.com/sony_xperia_5_iv-price-11838.php
https://redfm.ie/
https://en.m.wikipedia.org/'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result