#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)class\s+([A-Z]\w+)\s+(?:<\s+(\w+))?\s*{[\s\S]*?\n}"
Local $sString = "class Main < Console {" & @CRLF & _
" + main:Int () {" & @CRLF & _
" !String hello = "Hello, World!";" & @CRLF & _
" this.out(hello);" & @CRLF & _
" >> 0;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"class Foobar {" & @CRLF & _
" + foobar:None () {" & @CRLF & _
" #Some code..." & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")