re = /class\s+([A-Z]\w+)\s+(?:<\s+(\w+))?\s*{[\s\S]*?\n}/m
str = 'class Main < Console {
+ main:Int () {
!String hello = "Hello, World!";
this.out(hello);
>> 0;
}
}
class Foobar {
+ foobar:None () {
#Some code...
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end