import re
regex = re.compile(r"^id:\s*\d+\s+synset:\s*(?:\w+,)*\w+$", flags=re.MULTILINE)
test_str = ("SHOULD MATCH\n"
"id: 12345 synset: word1\n"
"id: 12345 synset: word1,word2\n"
"id: 12345 synset: word1,word2,word3\n"
"id:12345 synset:word1,word2\n\n"
"SHOULDN'T MATCH\n"
"id: abc synset: word1,word2\n"
"id: 12345synset: word1,word2\n"
"id: 12345 synset: *$%%/\n"
"id2: 12345 synset2: word1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")