re = /^id:\s*\d+\s+synset:\s*(?:\w+,)*\w+$/m
str = 'SHOULD MATCH
id: 12345 synset: word1
id: 12345 synset: word1,word2
id: 12345 synset: word1,word2,word3
id:12345 synset:word1,word2
SHOULDN\'T MATCH
id: abc synset: word1,word2
id: 12345synset: word1,word2
id: 12345 synset: *$%%/
id2: 12345 synset2: word1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end