using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(?:DO1210M|DO1215M|DO1270M)$)^DO\d{4}M$";
string input = @"DO1210M
DO1215M
DO1270M
DO1234M
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}