re = /^(?!(?:DO1210M|DO1215M|DO1270M)$)^DO\d{4}M$/m
str = 'DO1210M
DO1215M
DO1270M
DO1234M
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end