$re = '/^(?!(?:DO1210M|DO1215M|DO1270M)$)^DO\d{4}M$/m';
$str = 'DO1210M
DO1215M
DO1270M
DO1234M
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);