const regex = /^(.*)(\/comments\/)(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*)(\\\/comments\\\/)(.*)', 'gm')
const str = `https://www.reddit.com/r/RationalPsychonaut/comments/5m4rhv/a_satirical_blog_about_enlightenment_in_everyday/
https://www.reddit.com/r/swift/comments/5mriaj/i_just_released_a_swift_wrapper_for_the_llvm_api/
`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);