re = /^(.*)(\/comments\/)(.*)/m
str = 'https://www.reddit.com/r/RationalPsychonaut/comments/5m4rhv/a_satirical_blog_about_enlightenment_in_everyday/
https://www.reddit.com/r/swift/comments/5mriaj/i_just_released_a_swift_wrapper_for_the_llvm_api/
'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result