use strict;
my $str = 'https://www.reddit.com/r/RationalPsychonaut/comments/5m4rhv/a_satirical_blog_about_enlightenment_in_everyday/
https://www.reddit.com/r/swift/comments/5mriaj/i_just_released_a_swift_wrapper_for_the_llvm_api/
';
my $regex = qr/^(.*)(\/comments\/)(.*)/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";