using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:1()|2()|3())/sometext/sometext/(?(1)first)(?(2)second)(?(3)third)$";
string input = @"1/sometext/sometext/first
1/sometext/sometext/second
1/sometext/sometext/third
2/sometext/sometext/first
2/sometext/sometext/second
2/sometext/sometext/third
3/sometext/sometext/first
3/sometext/sometext/second
3/sometext/sometext/third
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}