import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:1()|2()|3())/sometext/sometext/(?(1)first)(?(2)second)(?(3)third)$";
final String string = "1/sometext/sometext/first\n"
+ "1/sometext/sometext/second\n"
+ "1/sometext/sometext/third\n"
+ "2/sometext/sometext/first\n"
+ "2/sometext/sometext/second\n"
+ "2/sometext/sometext/third\n"
+ "3/sometext/sometext/first\n"
+ "3/sometext/sometext/second\n"
+ "3/sometext/sometext/third\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}