import Foundation
let pattern = #"^(?:1()|2()|3())/sometext/sometext/(?(1)first)(?(2)second)(?(3)third)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1/sometext/sometext/first
1/sometext/sometext/second
1/sometext/sometext/third
2/sometext/sometext/first
2/sometext/sometext/second
2/sometext/sometext/third
3/sometext/sometext/first
3/sometext/sometext/second
3/sometext/sometext/third
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)