package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:1(/sometext/sometext/)first|2(?1)second|3(?1)third)$`)
var str = `1/sometext/sometext/first
1/sometext/sometext/second
1/sometext/sometext/third
2/sometext/sometext/first
2/sometext/sometext/second
2/sometext/sometext/third
3/sometext/sometext/first
3/sometext/sometext/second
3/sometext/sometext/third
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}