# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:1(/sometext/sometext/)first|2(?1)second|3(?1)third)$"
test_str = ("1/sometext/sometext/first\n"
"1/sometext/sometext/second\n"
"1/sometext/sometext/third\n"
"2/sometext/sometext/first\n"
"2/sometext/sometext/second\n"
"2/sometext/sometext/third\n"
"3/sometext/sometext/first\n"
"3/sometext/sometext/second\n"
"3/sometext/sometext/third\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.