// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:1(/sometext/sometext/)first|2(?1)second|3(?1)third)$").unwrap();
let string = "1/sometext/sometext/first
1/sometext/sometext/second
1/sometext/sometext/third
2/sometext/sometext/first
2/sometext/sometext/second
2/sometext/sometext/third
3/sometext/sometext/first
3/sometext/sometext/second
3/sometext/sometext/third
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}