#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?ms)!TIME!(?<AgentInitialResponseTime>[^!]*)!.*!NAME!(?<Agent>[^!]*)"
Local $sString = "!CI!!L!en!/LO!!TIME!1/1/2019 2:51:27 AM!/TIME!" & @CRLF & _
"!NAME!Rohi!/NAME!" & @CRLF & _
"!TEXT!Yes!/TEXT!!NAMEID!rohi@test.com!/NAMEID!!MID!13!/MID!!UTCEPOCHTIME!1546329087000!/UTCEPOCHTIME!!/CINST!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")