use strict;
my $str = '!CI!!L!en!/LO!!TIME!1/1/2019 2:51:27 AM!/TIME!
!NAME!Rohi!/NAME!
!TEXT!Yes!/TEXT!!NAMEID!rohi@test.com!/NAMEID!!MID!13!/MID!!UTCEPOCHTIME!1546329087000!/UTCEPOCHTIME!!/CINST!';
my $regex = qr/(?ms)!TIME!(?<AgentInitialResponseTime>[^!]*)!.*!NAME!(?<Agent>[^!]*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}