package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(C|Db|D|Eb|E|F#|F|G|Ab|A|Bb|B)(.*)$`)
var str = `F#maj7`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}