const regex = /^(C|Db|D|Eb|E|F#|F|G|Ab|A|Bb|B)(.*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(C|Db|D|Eb|E|F#|F|G|Ab|A|Bb|B)(.*)$', '')
const str = `F#maj7`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}