$re = '/^(C|Db|D|Eb|E|F#|F|G|Ab|A|Bb|B)(.*)$/';
$str = 'F#maj7';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);