using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z]{3}-\d{4}|[A-Z]{3}\d[A-Z]\d{2}";
string input = @"ABC-1234, RTE5J78, XYZ-9876, WSD4K22";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}