import re
regex = re.compile(r"[A-Z]{3}-\d{4}|[A-Z]{3}\d[A-Z]\d{2}", flags=re.MULTILINE)
test_str = "ABC-1234, RTE5J78, XYZ-9876, WSD4K22"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")