package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*(\w+)\s*=\s*\{`)
var str = ` author = {Tony Wood and Amélie Hunter and Michael O'Toole and Prasana Venkataraman and Lucy Carter}," `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}