re = /^\s*(\w+)\s*=\s*\{/m
str = ' author = {Tony Wood and Amélie Hunter and Michael O\'Toole and Prasana Venkataraman and Lucy Carter}," '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end