$re = '/^\s*(\w+)\s*=\s*\{/m';
$str = ' author = {Tony Wood and Amélie Hunter and Michael O\'Toole and Prasana Venkataraman and Lucy Carter}," ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);