# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[(\w*)\]\n/"$1":/g;t' <<< "[HEADER1]
{
key value
key value
...
[HEADER2]
{
key value
...
}
key value
[HEADER3]
{
key value
[HEADER4]
{
key value
...
}
}
key value
}
"