// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[(\w*)\]\n").unwrap();
let string = "[HEADER1]
{
key value
key value
...
[HEADER2]
{
key value
...
}
key value
[HEADER3]
{
key value
[HEADER4]
{
key value
...
}
}
key value
}
";
let substitution = "\"$1\":";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}