import re
regex = re.compile(r"\[(\w*)\]\n")
test_str = ("[HEADER1]\n"
"{\n"
"key value\n"
"key value\n"
"...\n"
"[HEADER2]\n"
"{\n"
"key value\n"
"...\n"
"}\n"
"key value\n"
"[HEADER3]\n"
"{\n"
"key value\n"
"[HEADER4]\n"
"{\n"
"key value\n"
"...\n"
"}\n"
"}\n"
"key value\n"
"}\n")
subst = "\"$1\":"
result = regex.sub(subst, test_str)
if result:
print(result)