import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+(\\d{3}|\\d{2}|\\d{1})\\s\\((\\d{3}|\\d{2}|\\d{1})\\)\\s(\\d{3}|\\d{2}|\\d{1})\\-(\\d{2}|\\d{1})\\-(\\d{2}|\\d{1})";
final String string = "+189 (377) 123-12-34\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}